
Совет пользователям: Отладка и контроль работы программы ПЛК 
DirectLOGIC. 

При написании программы можно использовать инструменты: PLC > Diagnostic >Syntax Check – 
проверка синтаксиса программы, View > XRef View (Cross Reference) – просмотр используемых 
элементов и мест их в программе, Tools > Compare programs – Сравнение программ.  
Для отладки  работы программы в DirectSOFT5 существуют следующие возможности: 
- Контроль состояния переменных в окне редактора программ – Ladder View 
- Контроль состояния программы из окон просмотра данных - Data View 
- Диалоговое окно Изменение значения -  Change Value 
- Использование редактора памяти – Memory Editor 
- Отладка с помощью тестового режима - Test Mode 
- Монитор перехвата данных – Trap Monitor 
- Контроль стека (только для DL440) – Stack Monitor. 
 
Контроль состояния переменных в оконе редактора программ – Ladder View 
 Использование режима Debug в окне редактора программ 
Чтобы наблюдать текущие значения переменных и состояние контактов и обмоток надо включить 
режим отладки Debug > Status. Этот режим устанавливается для активного окна.  В этом 
режиме Вы сможете:  

• Видеть состояние (статус) элементов по изменению цветовой подсветки; 
• Наблюдать за изменением текущих значений таймеров и счетчиков. 
 

Контроль состояния программы из окон просмотра данных -  Data View 
 Использование окна просмотра данных Data View 
Для отладки программы очень полезно просматривать процесс изменения состояния элементов и 
текущих значений, и в  этом отношении окно просмотра данных (Data View) позволяет сделать 
очень многое, а именно: 

• Видеть и изменять состояние (статус) элементов; 
• Читать и записывать значения цифровых данных; 
• Открывать несколько окон просмотра данных и помещать на экране в удобном месте; 
• По умолчанию окно просмотра данных закреплено на экране и его можно автоматически 

сворачивать, щёлкнув по кнопке с изображением канцелярской кнопки. Несколько окон 
просмотра данных можно представить в виде набора вкладок, как одно закреплённое или 
плавающее окно; 

• Окно просмотра данных можно сохранить с заданным именем; 
• Окна просмотра данных не привязаны к проекту и могут быть использованы в нескольких 

проектах. 
• Обновлении информации в окне производится с частотой, зависящей от параметров канала 

связи с контроллером (при использовании программного порта – несколько раз в секунду, при 
использовании ЕСОМ – несколько десятков раз в секунду). Реальную скорость обмена  
можно увидеть: PLC > Link Setup –Xref rate/sec). 

 Открытие нового окна просмотра данных Data View 

 

Новое окно просмотра данных может быть открыто любым из трёх способов: из главного 
меню Debug (Отладка) > Data View (Просмотр данных)> New, клавишами быстрого 
доступа Ctrl + Shift + F3 или щёлкнув по кнопке Data (Данные) на панели инструментов 
Status (Состояние). По умолчанию окнам просмотра данных последовательно 
присваиваются имена Data1,  Data2 и так далее. Это имя для текущего окна можно 
изменить, воспользовавшись диалоговым окном Options (Опции). На рисунке ниже 
представлен пример заполненного окна Data View . 
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  Окно просмотра данных содержит следующие компоненты: 
• Выбор режима изменений – добавляет/убирает колонку изменений -Edit. Когда колонка добавлена, 

изменения можно записать в ПЛК. 
• Формат данных –  изменяет формат данных в выбранной строке (Binary, Octal, BCD/HEX, Decimal,  

Signed Decimal, Real, Exponential, Text), отображаемый в колонке состояния (Status). 
• Размер формата – выбор размера формата данных (WORD -слово, DWORD – двойное слове). 
• Отмена изменений – отмена всех изменений, сделанных в колонке изменений. 
• Запись текущих изменений в ПЛК – с помощью этой кнопки можно записать в ПЛК значение для 

одного элемента, введённое в колонке изменений. 
• Запись всех изменений в ПЛК –  с помощью этой кнопки можно записать в ПЛК значения данных для 

нескольких элементов, введённые в колонке изменений. 
 

 Настройка окна просмотра данных 

 

Вид и свойства окна просмотра данных можно настраивать под конкретного пользователя. 
Для настройки окна просмотра данных щёлкните по нему, затем выберите Options или 
выберите в главном меню View > Options, или щёлкните по кнопке Opts(Опции) на панели 
инструментов. Появится диалоговое окно Options с открытой вкладкой Data View, как 
показано на рисунке ниже. 

 

 

 
Это окно откроется с параметрами, помеченными «галочками» по умолчанию в секции General 
Settings (Общие установки) на вкладке Display-1 (Изображение 1). Иногда бывает полезно 
дополнительно пометить «галочкой» флажок Col 1 shows display format (В колонке Element справа 
от элемента будет показан формат данных).  
 Выбор битов для отображения 
Секция Bit Display Settings (Настройка битов для отображения) справа от секции General Settings 
есть только на вкладке Display-1. Здесь можно выбрать (включить) один, два или три вида 
управления и контроля за битами, когда ПЛК находится в режиме отладке программы. 

• Status Bits (Биты состояния) – когда включён этот флажок, в колонке Status (Состояние) отображается 
состояние элемента, если включена кнопка состояния в колонке Edits (Изменения). 

• Pause Bits (Биты паузы) – когда включён этот флажок, то все каналы вывода (или другие логические 
элементы) продолжают работать, в то время как выбранные каналы вывода отключаются. 

• Override Bits (Биты принудительного управления каналами ввода/вывода) – когда включён этот 
флажок, выбранные в окне просмотра каналы ввода/вывода можно вручную включать и выключать 
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На рисунке ниже показано, как может выглядеть окно просмотра данных, когда включены все три 
вида управления и контроля за битами.  
 

 

 
ПРИМЕЧАНИЕ: Кнопки в колонке Edits отображаются только тогда, когда ПЛК находится в режиме 
RUN  выбран Status.  
Эти кнопки не действуют, когда в качестве протокола обмена данными выбран DirectNET. 
 Выбор документации для окон просмотра данных 
Справа от вкладки Display-2 расположена вкладка Doc (Документация). Документация (элементы, 
логические имена и прочее), отображаемая в колонке Element, включается и выключается здесь. 
Текущее окно просмотра данных также может быть переименовано здесь же с Data1, Data2, Data3 и 
так далее на любое другое подходящее имя. Новое имя для текущего окна просмотра данных 
вводится в поле Title (Заголовок). Имя может содержать до 32 символов. 
 Применение опций настройки 
Обратите внимание на три флажка в строке Apply options to: (Применить опции к:). Эти флажки 
находятся в окне Options (Опции), когда оно открыто. После нажатия OK, опции будут применены к 
тем окнам просмотра данных, которые вы задали флажками (Current, All, New). 
 Установка режима просмотра данных 
Окно просмотра данных можно перевести в режим только для чтения Read Only (no writes), если 
нужно запретить изменять данные кому-либо, кто просматривает их. Настройка производится на  
вкладке Mode (Режим)  
 Ввод данных в окно Data View  
Если впервые открывается новое окно просмотра данных, то колонки в нём пустые. Сначала надо 
ввести данные в колонку Elements (Элементы). В эту колонку можно вводить адреса элементов, 
адреса памяти или мнемонические имена.Dвод данных можно сделать и при отключённом ПЛК, 
затем подключить ПЛК для отслеживания работы программы. 
 Запись изменений состояний и значений 
Пользователь может изменить элемент или ввести данные в ячейку памяти. Изменения  
осуществляются в колонке Edits (Изменения). Все изменения помещаются в буфер перед тем, как 
они будут записаны в ПЛК. Наверху окна просмотра данных имеется три кнопки, которые относятся 
к колонке Edits. Кнопкой Clear Edits (Удалить изменения) полностью очищается буфер изменений и 
в него можно вносить новые изменения. В память можно вводить одиночные изменения, для этого 
просто введите значение в колонке Edits. После того, как изменение (ввод) сделаны, щёлкните по 
кнопке, на которой нарисована одна стрелка, указывающая на ПЛК, Write to PLC (Записать в ПЛК). 
Можно также сразу записать в ПЛК несколько значений данных или включить несколько 
управляющих реле. Изменения будут записаны в ПЛК все сразу (по одному в скан-цикл). 
 Автоматический ввод нескольких элементов 
Если нужно отследить группу управляющих реле С10, С11, С12 и С13, то введите С10, затем 
щёлкните по этой записи и удерживайте одновременно клавиши Ctrl + Enter. В колонку Elements 
(Элементы) будут вводиться управляющие реле с последовательными номерами до тех пор, пока 
не будет отпущена клавиша Enter. Если какой-либо элемент был ранее введён в окно просмотра 
данных, то щёлкните по мнемоническому имени или адресу этого элемента, затем воспользуйтесь 
клавишами Ctrl + Enter, как описано выше. Элементы будут введены последовательно ниже 
начальной точки и все другие элементы, которые были ниже начальной точки, будут смещены вниз. 
 Редактирование списка элементов 
Редактирование изменений можно осуществить с помощью стандартных комбинаций клавиш 
быстрого доступа: Ctrl +C для копирования, Ctrl + X для вырезки элемента и Ctrl + V для вставки 
элемента. 
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Для редактирования группы элементов надо выберать первый элемент в группе, затем клавишами 
Shift + Arrows отметить группу элементов по горизонтали или по вертикали. Или щёлкнуть по 
первому элементу группы и, удерживая клавишу Shift, протащить курсор мыши до последнего 
элемента. Выделенные элементы после этого можно удалить, вырезать, скопировать или 
одновременно задать им один и тот же  формат или размер. 
Элементы можно удалять из окна просмотра данных в любое время. Выберите элемент, щёлкнув по 
нему, затем или воспользуйтесь клавишей Delete, или выберите в главном меню Edit > Delete,  или 
щёлкните по кнопке Delete на панели инструментов редактирования, или щёлкните по элементу 
правой клавишей мыши и выберите Delete в выпадающем меню. Удаляемые элементы теряются 
безвозвратно. 
 Сохранение окна просмотра данных 
После того, как окно просмотра данных настроено для отладки программы, полезно его сохранить 
для того, чтобы его можно было открыть и использовать позднее. Если на экране отображается 
панель инструментов Debug , то щёлкните по кнопке Save (Сохранить) и появится диалоговое окно 
Save. Вместо имени по умолчанию (Data1, Data2  и так далее) окну просмотра данных можно дать 
другое имя, затем сохраните это окно просмотра данных в папке Projects , щёлкнув по кнопке Save. 
Диалоговое окно Save, можно также открыть из главного меню: Debug > Data View > Save . Если 
нужна ещё одна копия окна просмотра данных, то воспользуйтесь кнопкой Save As  на панели 
инструментов Debug  или в главном меню выберите Debug > Data View > Save As  
 Использование битов паузы 
Для того чтобы установить бит паузы для какого-либо канала вывода щёлкните по соответствующей 
кнопке паузы (с буквой «Р»). Щёлкните по кнопке без подписи для сброса бита паузы. Буква 'Р' в 
колонке состояния означает, что бит паузы установлен для данного канала вывода. 
 Использование битов, переводящих каналы ввода/вывода в режим принудительного 

управления (только для DL05/06/240/250-1/260/350/450) 
В режиме Override Bits (Биты принудительного управления каналами ввода/вывода), биты 
состояния могут быть установлены для каждого канала ввода и вывода в окне просмотра данных. 
Установка этих битов  позволяет управлять состоянием  каналов ввода/вывода с помощью 
программирующего устройства, а не полевым устройством, подключённым к модулю ввода/вывода. 
То есть это принудительное включение канала ввода/вывода в состояние включено или отключено. 
Для того чтобы установить бит принудительного управления для какого-либо канала вывода 
щёлкните по соответствующей кнопке ручного управления (с буквой «О»). Щёлкните по кнопке без 
подписи для сброса бита принудительного управления. Буква 'О' в колонке состояния означает, что 
бит установлен для данного канала ввода/вывода. 

 

ПРИМЕЧАНИЕ: Биты принудительного управления очищаются при переходе из режима 
программирования в режим выполнения программы. 
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Диалоговое окно Change Value (Изменение значения) 
Окно изменения значений можно использовать в режиме выполнения программы для изменения 
состояния дискретных элементов и изменения значений данных в памяти. Состояние каналов 
ввода/вывода изменяют с помощью кнопок внесения изменений, а значения данных изменяют, 
печатая новые значения в колонку Edits (Изменения). Внесённые изменения действуют только после 
того, как они будут записаны в ПЛК. 
 Использование диалогового окна Change Value  

 

Для того чтобы открыть диалоговое окно Change Value на панели инструментов Online, или 
воспользуйтесь клавишами Ctrl + Shift + F2, или, когда DirectSOFT не в режиме 
редактирования, дважды щёлкните по элементу, который нужно изменить. Появится одно из  
диалоговых окон. 

 
В окне отображается текущее значение элемента (Current Value). Текущее значение отображаемого 
элемента будет On / Off (Вкл./Выкл.) или содержимое адреса в памяти. 
 Ввод нового значения 
 Чтобы изменить состояние элемента из выключенного (Off) во включенное (On), просто щёлкните по 
переключателю On, который расположен под словом New.  
Чтобы записать данные в ячейку V-памяти, введите новое значение в поле New. Новое состояние или 
значение будут записаны в ПЛК после  щелчка по кнопке Write to PLC (Записать в ПЛК).  
Использование редактора памяти 
Ещё одним средством для отладки программ, которым обладает DirectSOFT 5, является Memory Editor 
(Редактор памяти). Редактор памяти можно использовать для отображения и изменения данных в нескольких 
соседних ячейках памяти. Это особенно полезно при вводе или изменении значений в V-памяти или вводе 
текстовых строк в блок V-памяти. 
Для вызова редактора памяти щёлкните по кнопке MemEd (Редактор памяти), которая расположена 
на панели инструментов Tools (Инструменты), или выберите в главном меню Tools > Memory Editor 
(Редактор памяти), или воспользуйтесь клавишами быстрого доступа Ctrl + Y. 
 

 

 Выбор адресов для просмотра 
Сначала воспользуйтесь кнопкой Find (Найти). Появится диалоговое окно для ввода адреса памяти, 
с которого начинается диапазон адресов для отображения и редактирования, затем щёлкните по 
кнопке ОК. 
После того как новые данные введены в поля данных, щёлкните по кнопке Write to PLC (Записать в 
ПЛК), чтобы обновить данные в ПЛК.  
Редактор памяти не показывает автоматически данные, введённые в ПЛК. Чтобы увидеть 
обновлённые данные, щёлкните по кнопке Read from PLC (Прочитать из ПЛК). 

5 



 

Отладка с помощью тестового режима Test Mode 
 Выбор тестового режима 
ПЛК DirectLogic поддерживают большинство операций тестового режима, которыми обладает 
DirectSOFT 5 (только ПЛК DL440 и DL450 поддерживают все операции тестового режима). 
Войдите в тестовый режим из режима выполнения программы или из режима программирования, 
щёлкнув по кнопке PLC Mode (Режим ПЛК) на панели инструментов Online, или выбрав в главном 
меню PLC > PLC Modes (Режимы ПЛК), или воспользовавшись клавишами быстрого доступа Ctrl + 
Shift + R. Появится диалоговое окно PLC Modes, показанное на рисунке ниже. Выберите 
переключатель Test  и затем щёлкните по кнопке OK. 
 

 

 
Если при выборе тестового режима ПЛК был в режиме выполнения программы (Run Mode), то ПЛК 
продолжит выполнение программы и на индикаторе режима ПЛК внизу окна DirectSOFT 5 текст Test 
RUN (Тестовый Режим выполнения.) 
  Окно тестовых операций 
 

 

Для использования тестовых операций, ПЛК должен быть в режиме тестирования программы (Test 
Program Mode).  
 Операции тестирования программы 
Для всех ПЛК DirectLogic в тестовом режиме имеется только четыре операции: 

1. Start PLC Scan (Начать выполнение программы) – эта операция переводит ПЛК в тестовый 
режим выполнения программы. ПЛК будет выполнять программу до тех пор, пока вы не 
щёлкните по кнопке Stop PLC Scan (Остановить выполнение программы). 

2. Stop PLC Scan – эта операция переводит ПЛК в Тестовый программный режим и 
останавливает выполнение программы в ПЛК. 

3. Single Scan (Выполнить один цикл программы) – эта операция запускает выполнение 
программы в ПЛК на один цикл и затем останавливает выполнение программы. 

4. Multiple Scans (Выполнить несколько циклов программы) – эта операция запускает 
выполнение программы в ПЛК на заданное количество циклов.  

Дополнительные тестовые операции применимые только для ПЛК DL440 и  DL450: 
Single Step (Выполнить один шаг программы) – эта операция запускает выполнение программы в 
ПЛК на один шаг и затем останавливает выполнение программы. 
Breakpoint (Точка останова) – эта операция определяет адрес команды, после выполнения которой, 
нужно остановить выполнение программы в ПЛК. Если щёлкнуть по кнопке ОК, то программа будет 
выполняться до тех пор, пока она не достигнет заданного адреса, затем ПЛК переходит в режим 
останова. 
BREAK Instruction (Команда останова) – эта операция меняет рабочий режим ПЛК с режима 
выполнения программы на режим тестирования программы. Эта операция позволяет сохранить 
данные в V-памяти и регистрах изображения тогда, как по команде STOP или при обычном переходе 
RUN -PGM эти данные теряются. 

 

Монитор перехвата данных – Trap Monitor 
 Доступ к монитору перехвата 
При работе с ПЛК DL06, DL250-1, DL260 и DL450 можно использовать дополнительный инструмент 
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диагностики - Trap Monitor (Монитор перехвата). Монитор перехвата предназначен для захвата 
данных элемента по заданному адресу до окончания цикла сканирования программы. Монитор 
перехвата полезен, если нужно просмотреть какую-либо  часть релейной логики в тестовом режиме 
выполнения программы.  
Чтобы воспользоваться монитором перехвата, или щёлкните по кнопке Trap (Перехват), 
расположенной на панели инструментов Debug (Отладка), если эта панель отображается, или 
выберите в строке главного меню Debug > Trap Monitor. Монитор перехвата можно использовать 
только в тестовом режиме выполнения программы - Test RUN. Если ПЛК не находится в Test RUN, 
то появится сообщение с вопросом, безопасно ли переключить ПЛК в режим Test RUN. Выберите 
кнопку «Switch to…» (Переключиться на…). Появится другое диалоговое окно, в котором это нужно 
подтвердить. Как только ПЛК переключится  в тестовый режим выполнения программы, появится 
диалоговое окно, показанное на рисунке ниже.  
 

В монитор захвата вводят адрес элемента и/или его псевдоним, а в области только для чтения 
диалогового окна просматривают данные этого элемента. Можно оставить адрес неизменным и 
менять псевдонимы для того, чтобы прочитать значения элементов по этому адресу. Или можно 
инкрементировать или декрементировать адрес, не меняя значения элемента для того, чтобы 
проверить данные по разным адресам. 
Другой способ использования монитора перехвата – это включить две кнопки перехвата (Trap). 
Когда эти кнопки включены, адрес можно инкрементировать или декрементировать и просматривать 
элементы по новым адресам. Область только для чтения тоже будет изменяться. 
Если вы хотите проверить данные в ячейках V-памяти, то оставьте диалоговое окно монитора 
перехвата таким, каким оно показано на рисунке выше, затем поместите курсор программирования в 
окне программы на элемент (блок) с адресом в нём. Теперь Вы можете прочитать данные элемента 
(блока)в области только для чтения монитора перехвата. 
Монитор перехвата обычно используется в комбинации с одним или несколькими окнами просмотра 
данных. Монитор перехвата полезен при просмотре математических операций в программе. Формат 
считываемых значений можно задавать (десятичный, шестнадцатеричный или восьмеричный).  
Щёлкните по кнопке в правом нижнем углу диалогового окна, чтобы открыть диалоговое окно, в 
котором можно задать формат данных. 
Контроль стека (только для DL440) 
 Доступ к монитору стека 
Монитор стека позволяет просматривать содержимое аккумулятора и стека данных.  
Доступ к монитору стека (Stack Monitor) осуществляется кнопкой Stack, расположенной на панели 
инструментов Debug , или выбором в строке главного меню Debug > Stack Monitor (Монитор стека). 
Монитор стека чаще всего используется с сегментами программы, где требуется отладка 
математических операций. 
Воспользуйтесь диалоговым окном, которое открывается после выбора в главном меню Debug > 
Test Mode Operations > Breakpoint (Точка останова) или командой BREAK (Останов) для того, 
чтобы проконтролировать содержимое аккумулятора ПЛК и стека данных по заданному адресу. 
Доступ к Breakpoint  горячими клавишами : SHIFT+CTRL+B (когда ПЛК в режиме Test Program) 
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